Top.Mail.Ru
Перейти к публикации

Рекомендованные сообщения

НЕЕЕт такой точно не нужен, его же чем-то управлять надо, а эти вещи очень дорогие

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Доброго времени суток, коллеги) Наконец-то пришла плата STM32F407VET6 и уже несколько дней пытаюсь подключить ее к ПК... безрезультатно... Установил драйвера с официального сайта, установил ST-LINK Utility (купил еще дополнительно китайский программатор ST-LINK). Пробовал подключать по USB (как писал автор темы, что он тупо по USB залил без какого-либо геморроя) - устройство определяется как Unknown Device. С ST-LINK такая же фигня: ST-LINK сам определяется, а плата в в ST-LINK Utility выдает No target connected. Но самое интересное, что при подключении платы - на ней начинает моргать светодиод, откуда следует вывод, что она рабочая. И ножки переставлял на BOOT0 и BOOT1, и дополнительно покупал ST-LINK - безрезультатно. Может быть кто-то сталкивался с данной проблемой? Как можно ее решить?

Скрытый текст

Операционка - Windows 7 x64... Но думаю не в винде проблема, т.к. пробовал и на Windows 10 x32 - та же история...

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
8 минут назад, Kein Engel Zlat сказал:

Доброго времени суток, коллеги) Наконец-то пришла плата STM32F407VET6 и уже несколько дней пытаюсь подключить ее к ПК... безрезультатно... Установил драйвера с официального сайта, установил ST-LINK Utility (купил еще дополнительно китайский программатор ST-LINK). Пробовал подключать по USB (как писал автор темы, что он тупо по USB залил без какого-либо геморроя) - устройство определяется как Unknown Device. С ST-LINK такая же фигня: ST-LINK сам определяется, а плата в в ST-LINK Utility выдает No target connected. Но самое интересное, что при подключении платы - на ней начинает моргать светодиод, откуда следует вывод, что она рабочая. И ножки переставлял на BOOT0 и BOOT1, и дополнительно покупал ST-LINK - безрезультатно. Может быть кто-то сталкивался с данной проблемой? Как можно ее решить?

  Скрыть содержимое

Операционка - Windows 7 x64... Но думаю не в винде проблема, т.к. пробовал и на Windows 10 x32 - та же история...

 

У меня та же беда, один в один. И плата и программатор такой же (3 дня назад получил), пробовал по USB - ноль результата. Проблему пока не пытался решать т.к нет времени совсем и сборку своей базы отложил да декабря, но будет интересно если у кого получится решить проблему. P.S. у меня  Windows 7 и 10 x64

  • Нравится 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я по началу тоже не мог разобраться, но проблема была в драйвере STM, потом прошил плату как говорят в этом видео ролике 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, piradik5 сказал:

я по началу тоже не мог разобраться, но проблема была в драйвере STM, потом прошил плату как говорят в этом видео ролике 

 

по USB шил? или через переходники?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

по usb, тоже купил stm link но он так и не пригодился

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 24.09.2019 at 7:00 PM, Axpion said:

 

 

Собственно приехал энкодер OMRON E6B2-CWZ6C 2500P\R. Закидывал напрямую, с резисторами на 220ом\383ом\510ом ситуация осталась такая же как и со старым энкодером.

У кого нибудь есть варианты из-за чего это может быть?

Изменено пользователем Axpion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Axpion Подключил правильно? Фото скинь. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
18 minutes ago, Sieben said:

@Axpion Подключил правильно? Фото скинь. 

Конечно верно. Перепутать нереально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Резюмирую. Нашел данный баг и обходной пока что путь. Можете начинать кидать в меня помидорами и тапками.

STM32F4 была подключена в порты USB 3.0. После я перекинул в другие 3.0 эффекта тот же. Однако потом решил закинуть в 3.1 и заработал нормально энкодер. Перепроверил в 2.0 и тоже все работает.

Собственно косяк в 4-ех портах версии 3.0 (материнка на x99 чипсете). Все остальные девайсы в них адекватно работают. Из принципа буду искать причину бага на этих портах.

P.S. проверю еще на старом энкодере интереса ради.

UPD. На старом энкодере в 18000ppr все тоже отлично работает.

Изменено пользователем Axpion
  • Нравится 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот есть на электро усилителе руля, выглядит норм. Да вот не знаю, будет ли этот вариант лучше чем MY 1018? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

н-кодер, есть ли разница для прошивки на сколько PPr он будет? я понимаю, что чем больше тем лучше.

Изменено пользователем NITOR

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
14 hours ago, NITOR said:

н-кодер, есть ли разница для прошивки на сколько PPr он будет? я понимаю, что чем больше тем лучше.

До 2500p\r берите. Думаю не меньше 600p\r.

Изменено пользователем Axpion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

@Axpion Спасибо

Изменено пользователем NITOR

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

всем привет, собрал все как по схеме у автора, все прошил, подключил.

Проблема в том что у меня руль если крутануть в сторону он просто вращается до бесконечности в одну сторону. Настройки выставил, которые упоминались ранее в теме тут. Что делаю не так?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
43 минуты назад, Loneperson сказал:

Фото скинь BTS или маркировку BTS напиши свою.

 

Screenshot_7.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Оба провода pwm поменяй местами. Каналы энкодера а,б. Тоже можно сменить. Но сначала провода pwm. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Я уже оставил все части, собрал все, и у меня возникли первые проблемы. Я получаю кодировщик diview.exe, чтобы прочитать меня Я поставил проверку колеса и двигатель ничего не делает. Он качнул прутья ММО и Аора движется, но начинает вращаться в одном направлении и не останавливается, пока я не отключу его USB. Кто-нибудь знает в чем проблема? Как мне настроить колесную проверку?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@djors сверху сообщения прочти. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это уже работает Он должен был повернуться, чтобы узнать это. Я двигаюсь вперед с первым испытательным проектом эха.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@djors  лучше переводи на английский язык, со своего родного. С испанского, та и с любого другого, сразу на русский, не очень хорошо у google translate получается. Так будет гораздо понятнее, что подразумевается. Ну и оригинал на испанском, тоже возможно не помешает) 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 03.11.2019 в 2:46 PM, Makc.St сказал:

 

Screenshot_7.png

Поменял местами pwm и заработало, буду заказывать другой контроллер двигателя, у меня маркировка gag523.

В 03.11.2019 в 5:30 PM, Sieben сказал:

Оба провода pwm поменяй местами. Каналы энкодера а,б. Тоже можно сменить. Но сначала провода pwm. 

Спасибо, помогло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот уж эти GAG523 потрепали многим нервы и мне в том числе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Начало положено, за основу взял донора logitech momo с мертвой электроникой, на нем опробую всю электронику и надо будет браться зимой за новую механику.

Потихоньку надо закупить новый двигатель (пока не могу определиться какой выбрать) и нужен новый контроллер движка, а то и не один.

IMG_20191104_202156ggg.jpg

Изменено пользователем Loneperson
  • Нравится 4

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

большое спасибо за совет @sieben, я прошел проверку колес (линейный режим пошагового журнала 2) моему ts-pc и моему проекту под названием SR1. Можете ли вы сделать какие-либо выводы?

Screenshot_2019-11-05-13-38-21-773_com.miui.gallery.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

  • Похожие публикации

    • Автор: Randaewoo
      Планирую сделать себе педали, задумываюсь о решении всунуть в них 3 тензодатчика такого типа:

      Педаль газа, сцепления (предварительно 5кг)
      Педаль тормоза (20кг)
      В комплекте идут усилители XFW-HX711:

      Собственно вопрос:
      Как мне это все законектить и вывести на разъем rj12 для подключения к базе руля на основе платы STM32F4VE с прошивкой MMOS FFB 2014.
      Буду благодарен за ответы и возможные корректировки, буду прислушиваться к советам по улучшению.
       
    • Автор: Beg
      Всем привет, решил я создать отдельную тему под свой проект, перед началом я бы хотел выразить благодарность за технические консультации следующим пользователям портала:
      @Caravangoes
      @DarkGracius
      ну что, погнали! :)
      в поисках б/у коллекторного мотора постоянного тока типа MY1020 ну и "подобных", совершенно случайно наткнулся на Болгарский двигатель PIK-12 3/10-1 в состоянии почти нового, и после консультаций с @DarkGracius и изучении его темы на подобном моторе https://forum.simracing.su/topic/3830-narodnyy-directdrive-na-motorah-postoyannogo-toka/
      был начат свой проект со своим видением прекрасного :)
      задняя крышка была просверлена для установки корпуса/держателя энкодера (omron 600 ppr)
      вал просверлен сверлом на 5мм, нарезана резьба м6, вкручена шпилька для соединения с муфтой энкодера, корпус/держатель энкодера напечатан на 3д принтере

      заменил штатные провода на мотор (использовал кабель КГхл 2х4мм)

      для крпеления мотора в гараже был найден "маленький" уголок 75х75х6 мм
      выпелен, просверлен и покрашен


       
      на вал мотора установлена 3д печатная быстросъемная муфта
      быстросъемная муфта представляет из себя разрезанное шлицевое соединение, сжимаемое зажимом-эксцентриком
      ну и для "+15 лошадей" мотор был обтянут пленкой под карбон

      на этот "настольная" часть была закончена
      от мотора идет жгут проводов (силовой кабель на мотор и экранированый кабель на энкодер) к блоку управления
      блок управления собран на МК STM32 и 2х BTS 7960

      //тут меня сейчас закидают какашками, но я не подключал скрутку VCC+R_EN+L_EN к +5В - это дало эффект, что когда FFB=0 руль "абсолютно висит в воздухе" и вращается свободно без сопротивления, если же подать постоянное питание на эту скрутку, то обмотки мотора закорачиваются Н-мостами и не дают ему так свободно вращаться - еще раз повторюсь разница есть когда отсутвует выходный сигнал FFB//
      корпус блока так же напечатан на 3д принтере
      ]

       
      мощный блок питания был куплен у товарищей майнеров
      тока у него конечно с запасом...




      он сильно шумел вентилятором, и на скорую руку было сделано колхозное решение для уменьшения шума вентилятора, путем уменьшения его напряжения с 12 до 4 Вольт
      (сильно не смеяться)
      ]
      над коробкой с STM32 и BTS установил вентилятор
      чтобы вентилятор не работал постоянно, между ребер BTS вставил термостат KSD9700 с включением на 50 градусах
      ну и эта коробка установлена верхом на блоке питания
      спереди на коробке "clipping led"
      сзади разъем RJ45 для подключения энкодера и USB шнурок для подключения к ПК
      следом за коробкой поставил розетку РС-102 для подключения кабеля на мотор

       



      ну вроде пока все... если что забыл - спрашивайте
      замеры максимального момента (софт лок) дали усилие 10кг на рычаге 81мм (8,1 НМ)
      графики степ теста c баранкой (китай 320мм) и без:
       

       
       
      /руль после выключения FFB не останавливается т.к. как я говорил выше - мосты отключатся и он болтается несколько раз между софт локами/
      график линейности усилия

      продолжение следует)
  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×
×
  • Создать...