Top.Mail.Ru
Перейти к публикации

cahek2202

Юниоры
  • Публикации

    30
  • Зарегистрирован

  • Посещение

  • Дней в лидерах

    1

Последний раз cahek2202 выиграл 2 октября

Публикации cahek2202 были самыми популярными!

Репутация

9 Обычная

О cahek2202

  • Звание
    Новичок
  • День рождения 02/22/1991

SimRacing

  • Руль
    G27 Racing

Информация

  • Имя
    Александр
  • Город
    Москва

Посетители профиля

Блок посетителей профиля отключен и не будет отображаться другим пользователям

  1. не всем подойдет, у меня подшипник толстый, почти до обмоток статора доходит, у меня даже места нет для печатной проставки. Ну и на разных моторах подшипники по разному сидят, на одном у меня потряси и выпадет, на втором запресован так, что только колотушкой и молотком выбить смог и пожалел потом, когда обратно запресовывал - крышка треснула.
  2. я два сверла убил и так и не смог насквозь просверлить, сначала 5 мм пробовал, потом на 3 мм перешел с мыслями потом рассверлить то проще будет, короче тройку закусило и оно там обломилось. Пятерка затупилось, точить теперь надо, причем сверла вроде не китайские, Bosch. В итоге сделал болгарином поперечный надрез и протянул провода... Самое обидное что сверлил не руками, специально поперся, думаю на сверлильном станке сделаю чтобы все четко, ровно было...
  3. Вообще планирую с абсолютным, но первый odrive с неисправным драйвером его спалил, жду что быстрее будет - второй приедет или по России отдельно чип энкодера доберется, тогда в этом перепаяю. На данный момент все тесты с инкрементальным энкодером 600 ppr проводятся. Настройки на скрине. У меня есть предположение что пины не совпадают с прошивкой, потому что кнопка на Z не сбрасывает энкодер в начальное положение, хотя на первой плате (с неисправным драйвером) все отлично работает. Поэтому и просил исходники прошивки, хотел проверить какие пины на что назначены и свериться с имеющимися у меня платами. В общем как будет время - напиши пожалуйста) уже руки чешутся покатать)
  4. @propeler предыдущее сообщение устарело) с обеими платами разобрался, на одной из китая действительно мертвый drv8301, на второй плате сам дурак, энкодер не так подключал. В общем пока со второй платой работаю. Значения с энкодера получаю, в свойствах OdriveWheel крестик бегает туда-сюда, в настройках все задал, но калибровки при включении как ты писал в посте выше не происходит, на wheelcheck тоже не реагирует, короче усилия никакого на моторе нет. При этом через родную прошивку odrive я этим мотор-колесом кручу, все нормально. То есть и плата и мотор-колесо в рабочем состоянии. Куда копать/смотреть?
  5. ну у меня вопрос не в деньгах, а в хобби, люблю я всякие железки ковырять это раз, а во вторых там предзаказ только на вторую половину ноября, плюс пару недель на логистику, к декабрю только приехала бы... с этой я не планировал так долго ковыряться)
  6. @propeler выложи пожалуйста исходники прошивки, или в лс скинь, замучался уже вслепую воевать... Два odrive в наличии, на одном вместо 5В почему то 8 с драйвера приходит, на нем спалил AS5048A, взял инкрементальный энкодер, на нем завелось, в joy.cpl крестик бегает вправо-влево, но на моторе глухо... есть предположение что все-таки драйвер мертвый. Подвернулась тут оригинальная плата odrive на два мотора, правда старой ревизии, тут 5В стабильные, но данные с инкрементального энкодера не считывает... ползунок на месте висит... либо прошивка для него не подходит, либо я хз даже что, 5В энкодеру не хватает... короче я близок к заказу CSL DD)))
  7. без разницы @DL70 а смысл? Стоят довольно дорого относительно того же колеса от гироскутера, а момента мало.
  8. очередность чего? И как ты неправильно подключишь мотор?
  9. ну у меня в общем и целом собрана, пытаюсь завести, может к следующим выходным отзывы появятся, пока не заводится, есть предположение что абсолютному энкодеру поплохело и он помер когда ему вместо 5 вольт 8,5 прилетело) в общем надеюсь к выходным заведу и потестирую)
  10. у меня такое было когда питания не хватало, на сайте Odrive советовали взять другой usb кабель, подключить напрямую без хабов, ну и желательно в задний USB порт системника. Начни с этого, не поможет - скорей всего с odrive уже разбираться придется... Еще можно попробовать скачать zadig и драйвера поставить на неизвестное устройство.
  11. Короче собрал сегодня бомж крепление для теста... широкое малость получилось, но подпилить всегда можно) цена вопроса: - Крепление для рейлинга Delinia 2x4 см - 5 шт (94 руб/шт, самая затратная часть) - 470 руб - Уголок алюминиевый 20х20х1,2 мм длиной 1 м - 1 шт (94 руб) - 94 руб - Держатель балки левый - 1 шт (78 руб) - 78 руб. - Держатель балки правый - 1 шт (78 руб) - 78 руб - угловой элемент для рейлинга - 1 шт (70 руб) - 70 руб. Итого 790 рублей, плюс час другой времени и получилось такой франкенштейн-крепление, всякие заклепки/болты не считаю, их там от силы рублей на 15-20) ну для теста и пробы пока сойдет. Квик релиз не успел прицепить, если завтра руки дойдут дополню ощущения о жесткости и удобстве крепления. В целом поперек жесткости за глаза, верстак шатался вместе с креплением)
  12. ЗАВЕЛ!!!!! Как ты и сказал решил проверить обвеску конвертера, все нормально было, прочитал весь даташит, перевел все что относится к конвертеру, решил протестить все выводы которые к нему относятся... Короче внезапно при постановке щупов на GND и 55 пин DRV8301 EN_BUCK он стартанул!!! Щупы убрал - выключился, поставил - опять стартанул, подержал секунд 30, и стало стабильно работать. При включении/выключении питания тоже стал стабильно стартовать. Вообще хз что было, но теперь и питание стартует и в винде сразу стал определяться. Завтра начну раму собирать. Спасибо за совет))
  13. @propeler спасибо, тоже нашел уже, я сделал проще - подключил питание и измерил напряжение на выходе на 52 ноге. 0,001В показал... судя по всему драйвер дохлый... вот гуглю как его еще проверить можно. А то он 730 руб. стоит, плюс перепаять как то нужно... А не подскажешь почему при подключении платы она может неопределяться? Это первый вопрос и второй - твоя прошивка подойдет для двухмоторного Odrive 24В?
  14. Парни, есть кто в электросхемах разбирается? Суть в чем, при подаче питания на разъем DC у меня нет питания на STM, и не горит PWR. При подаче питания от USB на ПК на пины VCC и GND светодиод загорается, я могу прошить STM. После прошивки выключаю DFU режим и у меня odrive определяется как неизвестное устройство (Ошибка 43 сбой запроса дескриптора). Есть предположение что может питания не хватает, ну и в целом хотелось понять в чем проблема. В общем дошел до AMS1117 и понял что на нее напряжение не приходит, дальше плату разглядеть не смог что и куда идет, нашел схему на оф. сайте Odrive (https://nas.gos-dom.ru/sharing/fGuSe5meT). Там на Vin AMS1117 подается 5V, а вот откуда эти 5V берутся - так и не нашел... Если кто может помочь - буду благодарен)
  15. @Dimonozawr Ну у меня проблема несколько другая, я уже и 24В блок попробовал, у меня PWR не загорается. Тебе нужно для начала определиться через что шьешь - USB или Stlink? Дальше уже будем пошагово смотреть, ну или давай в дискорд пошли, там быстрее, чем тут клавиши набивать...
×
×
  • Создать...