Перейти к публикации

dvkokh

Юниоры
  • Публикации

    34
  • Зарегистрирован

  • Посещение

Репутация

5 Обычная

О dvkokh

  • Звание
    Новичок

Информация

  • Имя
    Денис Кох
  • Город
    Балашиха

Посетители профиля

Блок посетителей профиля отключен и не будет отображаться другим пользователям

  1. Еще вопрос и еще забыл добавить, при min force выкрученном на максимум тест step log проходит нормально.
  2. Я вроде не глупый да) Но до конца не разбираюсь в вопросе, это вообще мой первый опыт постройки чего то подобного. С одной стороны вроде всё просто, а с другой стороны есть куча нюансов, в которых тоже хотелось бы разобраться, поэтому я и спрашиваю совета. Подкрутив значения min/max force заработало и без 5v, только без 5v поведение немного другое, вчера было мало времени потестировать и так и так, до конца еще не понял как лучше, но ощущение что без 5v feedback не такой острый, зато мне больше понравилось, что руль лёгкий когда нет никаких эффектов. Еще странно начал вести себя тест Step log 2, во первых он иногда долго думает прежде чем запуститься, во вторых он сначала как бы крадется до определенного уровня и только потом начинает возвращаться на место, и то руль во время теста возвращается не в центр. То ли я в MMOS tool что-то не то накрутил, но есть подозрение, что новые бтски еще хуже старых.
  3. Советы и инструкции принял, буду копаться в настройках. Бтски заказанные с али приказали долго жить после тестирования разных настроек, хорошо что достались бесплатно. Как куплю новые буду тестировать ещё.
  4. Со всеми проблемами разобрался, всё заработало при переподключении stm32 к пк. И в видео я говорил о том, что захватывается вторая ось, проблема была в том, что провод этой оси небыл ни к чему подключен, вообщем теперь всё работает идеально.
  5. Педаль от BMW работает и, вроде, вполне адекватно себя ведёт без конденсаторов. Цена вопроса 1000 руб. Наверное пойду на разборку за еще одной педалью, вытащу оттуда датчик холла для педали тормоза. Единственный момент, подключал всё по схеме, но контакт который идет на PB0 никак не реагирует на педаль. На PB1 работает нормально. С проводами и подключением всё порядке. В чем может быть проблема? И еще вопрос, есть какая нибудь программа чтобы потестировать оси? Посмотреть доходит ли уровень до 100 процентов при полном нажатии на педаль.
  6. @FSUP Надо тоже поэксперементировать, понять как лучше. @Basma4 Извиняюсь за глупые вопросы, но пока плохо разбираюсь в схемах... Я правильно понял, что конденсатор с выходного сигнала ставится вот так? Т.е. провод с выходным сигналом как шел так и идёт, просто к нему сбоку припаивается конденсатор?
  7. @Basma4 Я правильно понимаю, что на потенциометр/датчик холла нужно кидать 5в, а выходной сигнал уже к контактам PB0/ PB1 на плате? Купил на разборе электронную педаль газа от BMW со встроенным датчиком холла, хочу попробовать подключить, но она на выходе выдает от 0,5 до 4,5 вольт, надо будет смотреть как она себя поведет. @FSUP А как лучше? По сути если топить в сторону реалистичности, то руль и должен быть немного туговат в простое, если сравнивать с авто с ГУРом, на авто с электро усилителем полегче конечно руль.
  8. Вот подстава, я думал может хотя бы с датчиками холла stm нормально будет работать. Потенциометры не хочется ставить, хотя я так понимаю с ними тоже всё плохо. Вроде ферритовые кольца частично помогают решить эту проблему. Есть ещё способы побороть дерганье? Например повесить педали на контроллер, а контроллер уже цеплять к STM? Нашел гайд по фильтрации шумов с аналоговых датчиков. Работает на ардуино. Надо будет попробовать. https://alexgyver.ru/gyverfilters/
  9. Коллеги, кто-нибудь подключал педали на датчиках холла к STM32? Как они себя ведут? Будет ли это вообще работать?
  10. @Beg конденсаторы не ставил и, наверное, не буду, хочется как можно компактнее сделать. Но если новый блок питания будет так же себя вести, то, видимо, придется. @Basma4 как раз сейчас поеду за подобным на 20А
  11. @Buxou У меня валяется где то на 600 ватт от старого компа, но он 12в, хотелось бы 24, говорят фидбек повеселее работает. Куплю ватт на 500, надеюсь этого хватит. На серверные что-то ценники огромные, не хочется столько денег тратить на блок питания.
  12. Вообщем всё работает с одним жирным НО. При включении некоторых тестов тухнет блок питания, помогает выдернуть его из розетки и обратно включить. В чем может быть проблема? он просто не вывозит получается? Мотор на 300вт, блок питания китайцами был заявлен на 350... еще за него и переплатил чтобы в корпусе был.
  13. @Beg Премного благодарен. BTS на чипах GAC913 вроде нормально работают, но по твоему совету всё-равно сделал возврат средств на Aliexpress, сразу закрыли спор в мою пользу. Сегодня вечером буду тестировать руль, уже потом точно смогу сказать насчет этих BTS.
×
×
  • Создать...